macOS Apps Curiostet macOS

Sådan rettes: Ikke-understøttet bibliotek i macOS Photos app

Sådan rettes Photos fejl: Ikke-understøttet bibliotek - biblioteket "Photos Library.photoslibrarybibliotek ”Er fra en nyere version af Photos. Opgrader venligst Photos for at åbne dette bibliotek

I dette tutorial - Vi viser dig artiklen hvorfor fejlen opstår "Ikke-understøttet bibliotek”Når vi åbner en boghandel (Photos Library.photoslibrary) oprettet af applikationen Photos udviklet af Apple for macOS.

Ligger i mappen /Users/username/Pictures, fotoboghandel “Photos Library.photoslibrary" er det bedste leder for opbevaring, redigering og sortering af billeder og videoer importeret eller lavet med iPhone. Det er nok at have iCloud Photos aktiveret på applikationen Photos fra Mac og iPhone, så billeder og videoer vises automatisk på begge enheder. Eller på andre enheder, som du har samme konto til iCloud og synkronisering aktiveret Photos.

Når vi har to eller flere enheder Mac, og billederne er alle synkroniseret, er der den situation, at når vi ønsker at åbne boghandlen Photos, at være intimpindu har fejlen:Ikke-understøttet bibliotek - biblioteket "Photos Bibliotek.photoslibrary”Er fra en nyere version af Photos. Opgrader venligst Photos for at åbne dette bibliotek"

Ikke-understøttet bibliotek
Ikke-understøttet bibliotek

Hvorfor vises fejlen "Unsupported Library", når vi vil åbne et fotobibliotek (photoslibrary) Den Photos

"Photos Library.photoslibrary”Er et fotobibliotek oprettet af applikationen Photos. Applikation udviklet af Apple, indfødt på macOSDet den er opdateret med operativsystemet.

Vi tager scenariet, hvor vi har to enheder Mac og en af ​​dem har en nyere version af macOS.
Derefter da fotobiblioteket blev oprettet den Mac som har en version af macOS nyere, er det meget muligt, at den ikke kan åbnes på en Mac med en ældre version af macOS. Men pas på, dette sker kun, når du gemmer."offline”Fotoboghandel (boghandel.photoslibrary), på en ekstern harddisk eller andre datamedier.

Hvis vi f.eks. har, har vi en MacBook cu macOS Catherine og en anden Mac cu macOS Monterey, og begge har iCloud Photos, vil der ikke være noget problem med at åbne applikationen Photos. I det scenarie, hvor boghandlen "Photos Library.photoslibrarybibliotek ”blev oprettet den macOS Monterey, der derefter kopieres til en ekstern harddisk, vil ikke længere kunne åbnes på MacBook cu macOS Catalina, bliver oprettet på en nyere version af macOS.

Asadar, boghandler "Photos Library.photoslibrarybibliotek ”kan ikke åbnes på en version af macOS ældre end den, den er skabt til. Der er dog mulighed for, at vi kan få adgang til billederne uden at åbne biblioteket i applikationen Photos.

Sådan får du adgang til billeder fra "Photos Library.photoslibrarybibliotek ”hvis biblioteket ikke kan åbnes i applikationen Photos

Hvis vi kommer indpindu har fejlen "Unsupported Library", når du vil åbne "Photos Library.photoslibrarybibliotek ”i Photos og du kan eller vil ikke update til den seneste version af macOS, der er en anden mulighed. Du kan fysisk åbne dette bibliotek og udtrække billeder og videoer manuelt.

1. Højreklik på filen "Photos Library.photoslibrarybibliotek "klik derefter på" Vis pakkeindhold "

Vis indholdet af pakke
Vis indholdet af pakke

2. Gå til mappe "originals", Hvor vi finder flere mapper med navne fra 0 til 9 og A til Z. I disse mapper er alle billederne i .dng, .heic, .jpeg og videoformater i .mov-format.

originaler Photos
originaler Photos

Desværre er de ikke sorteret i en relevant kilde, men hvis du udpakker dem alle i én mappe, kan du bruge sortering efter dato til at sætte dem i kronologisk rækkefølge.

Sådan rettes: Ikke-understøttet bibliotek i macOS Photos app

Om forfatteren

stealth

Jeg er glad for at dele erfaringer i computere, mobiltelefoner og styresystemer, web-projekter til at udvikle og levere de mest nyttige tutorials og tips.
Jeg kan godt lide at "spille" på iPhone, MacBook Pro, iPad, AirPort Extreme og operativsystemer macOS, iOS, Android og Windows.

Efterlad en kommentar